Page 1 sur 1

[Forum] Problème avec 2 pièces jointes

Posté : 24 mai 2018, 11:53
par darinze
En rapportant un bug sur la localisation affichée dans mon profil, je suis tombé sur un nouveau problème qui se produit lorsqu'il y a 2 pièces jointes (deux images) dans un post

(peut-être cela se produit avec 3, ou même plus, je n'ai pas essayé).

Exar Kun me demandait des précisions sur le bug, je voulais mettre des shoots écran.
J'utilise pour cela la fonction "Fichiers joints".
J'ai uploadé le premier JPG, un screen shot de mon profil, et je l'ai inséré dans le post : OK.
J'ai uploadé le second JPG, un autre screen shot de mon profil, et je l'ai inséré dans le post : OK.

Le problème se produit lorsque j'appuie sur le bouton Apercu pour vérifier mon message avant de poster.
Je remarque que systématiquement à chaque aperçu, l'image que j'ai uploadée en second disparaît, ne reste que la première, dans la liste des "Fichiers joints".
Logiquement, une mention figure dans le post : "Le fichier machin.jpg n'est plus disponible".
Je réuploade, mon image revient dans la liste des fichiers joints, j'aperçuise : boum, elle disparaît de la liste.

Après plusieurs tentatives (reupload->ok, aperçu->ko), je poste sans aperçu, et là je m'aperçois que la mise en page a un peu merdé, voir le post ici http://www.starwars-holonet.com/forum/v ... 869#p41869
- le post affiche clairement "le fichier profil.jpg n'est plus disponible" au premier paragraphe sous la première citation,
- au second paragraphe, il m'affiche pourtant cette première image (celle qui manque soi-disant au dessus) alors qu'en vérité, à cet endroit-là, j'avais mis la seconde image,
- et ladite seconde image apparaît finalement tout en bas du message, là où je ne l'avais absolument pas demandée.

Re: [Forum] Problème avec 2 pièces jointes

Posté : 24 mai 2018, 14:33
par Exar Kun
Test : upload de 3 images + aperçu + publication (mais sans intégration dans le message)

EDIT : l'aperçu fonctionne correctement.

Re: [Forum] Problème avec 2 pièces jointes

Posté : 24 mai 2018, 14:34
par Exar Kun
Test : upload de 3 images + tentative d'intégration (dans l'ordre : Val, Qi'Ra puis Beckett) + aperçu.
Le fichier joint perso_val.jpg n’est plus disponible.
Le fichier joint perso_qira.jpg n’est plus disponible.
perso_val.jpg
perso_val.jpg (7.13 Kio) Vu 1048 fois
L'aperçu fonctionne correctement.

Re: [Forum] Problème avec 2 pièces jointes

Posté : 24 mai 2018, 14:39
par Exar Kun
Test après un fix : upload de 3 images + tentative d'intégration (dans l'ordre : Val, Qi'Ra puis Beckett) + aperçu.
perso_val.jpg
perso_val.jpg (7.13 Kio) Vu 1046 fois
perso_qira.jpg
perso_qira.jpg (10.4 Kio) Vu 1046 fois
perso_beckett_tobias.jpg
perso_beckett_tobias.jpg (8.34 Kio) Vu 1046 fois
(l'aperçu fonctionne)

Re: [Forum] Problème avec 2 pièces jointes

Posté : 24 mai 2018, 14:40
par Exar Kun
On dirait que c'est bon :-)

Re: [Forum] Problème avec 2 pièces jointes

Posté : 24 mai 2018, 16:35
par darinze
Super Exar !!!!
Réactif et efficace, bravo.
Image